WPML Support

WPML is a popular plugin for creating multilingual WordPress sites. Some of our plugins offer limited support for WPML, while others don't — this guide provides a breakdown of the current situation.

Plugins known to be mostly compatible with WPML

🔔 Note: Although we've worked hard to improve compatibility between WPML and the plugins listed in this section, complete compatibility is not guaranteed.

 

WPML and its associated plugins – as well as our own plugins – are constantly being updated and, regrettably, that makes it difficult to ensure 100% compatibility at all times ... however, a high degree of compatibility exists with the following plugins:

  • The Events Calendar
  • Events Calendar Pro
  • Filter Bar

Plugins that do not currently support WPML

  • Event Tickets
  • Event Tickets Plus
  • Community Events
  • Community Tickets
  • Eventbrite Tickets
  • Event Aggregator (although you could "cheat" a little - click here to learn more)

When will WPML support come for all plugins?

We do not have any firm plans to add WPML support to all of our plugins but are exploring a future model in which extensions will provide the compatibility layer.

Further Reading

To learn more about using WPML in parallel with our own plugins, please check out the following articles here on the knowledgebase:

Finally, we suggest you have a look at this article by WPML, which describes with great detail how to build multilingual events websites using The Events Calendar and WPML.