PHP Version Requirement Changes

We have decided to change our minimum required PHP version from 5.2 to 5.6. This change will benefit our products and—most importantly—our users. We’ve got you covered and can take you through the steps on how to make this change, and will explain why this change will be beneficial for all of us.

What is PHP?

In its simplest terms, PHP is the language that WordPress is written in. PHP acts as the foundation on which your WordPress site is run on, and the more recent the version of PHP your site uses, the faster and more secure your site will be.

It’s important to note that PHP versions below 5.6 generally don’t receive security fixes, meaning they’re no longer maintained. This could—and often does—leave a site running older versions of PHP vulnerable to hackers.

According to WordPress.org, site owners should care about PHP because of the three things that site owners care about the most:

“First, they want their website to work as expected when people visit it—we often call this site availability. Second, another major concern is how fast the site loads and functions, or site performance. Finally, you likely want your site to make use of all the latest and greatest tools, or features.”

Why are we making this change?

Using a more recent version of PHP will not only help us build a better product—it’ll also help to cut down on support time for outdated PHP versions. This change will furthermore create a better testing environment for us so that we can get bug fixes out more efficiently. These things, along with improved security and performance, will benefit not only our team but our users as well.

With an updated version of PHP, your site can handle more visitors and can run faster than with an outdated version. All of these things will benefit not only our team but our users as well.

Who else has implemented this change?

WordPress.org itself now recommends upgrading to version 7.2, as they outline in this article:

https://wordpress.org/support/upgrade-php/

WooCommerce also recommends PHP version 7.0 or greater, as stated on their website.

As part of this trend to update to more recent PHP versions that we are already seeing, Yoast SEO also follows the same requirements that WordPress itself follows.

Which plugins are affected?

This change will affect the following plugins:

  • The Events Calendar
  • Events Calendar PRO
  • Filter Bar
  • Event Tickets
  • Event Tickets Plus
  • Eventbrite Tickets
  • Community Events
  • Community Tickets
  • Image Widget Plus

When is this happening?

If your site is running PHP version 5.5 or lower, you’ll begin to see an admin notice around the end of June 2018; this notice will serve as a gentle reminder that you should begin to consider updating, as we will begin to remove support for older versions of PHP in the near future.

🔔 Note: You can always find our current system requirements here, so that you can always stay up-to-date.

How can I make this change?

First, check which PHP version you are using. You can do this by going to Events Settings →  Help in your wp-admin and checking out your system information, like in the following screenshot:

If you’re using PHP version 5.5 or below, you’ll want to begin thinking about making this change. If your web host provides a cPanel for administering your site’s server, you can often find one-click installs of more recent PHP versions.

Otherwise, you can contact your host to make this switch easier. Usually, all that’s required is a quick ping to their support team asking for a PHP version increase.

To make things easier for you, here’s a letter you can send to your host, as recommended by WordPress.org:

I’m interested in running the open-source WordPress <https://wordpress.org/> web software and I was wondering if my account supported the following:

  • PHP 7.2 or greater
  • MySQL 5.6 or greater OR MariaDB 10.0 or greater
  • Nginx or Apache with mod_rewrite module
  • HTTPS support

Thanks!

If your host doesn’t have updated versions of PHP available, we’d recommend switching to a host that does. We currently recommend the following hosts, which will make switching your PHP version easier:

Are you still encountering errors with PHP 5.6?  Check out Error: Publishing Failed on PHP 5.6

If you have any additional questions on this process, feel free to reach out to us over on the Help Desk!