Version compatibility

For proper plugin functionality, it's important to run compatible versions of The Events Calendar alongside any of our other add-ons. The best way to ensure compatibility between our plugins is to always use the latest available plugin releases for your version of WordPress.

If you are running disparate versions, you'll see a message in your WordPress admin that looks something like this:

KB - versions

If you find yourself getting a message like this, you'll want to check for updates to your plugins. Keep in mind that if you do not have an active license key in your plugin settings, you won't be able to update. Any license keys that are currently activated on your WordPress site will be shown on your WordPress site's backend under Events > Settings > Licenses. You can review all of your account's license keys and subscriptions from your TheEventsCalendar.com License Keys page.

We strongly recommend that you run current versions of our core and premium plugins at all times to prevent errors and to stay up to date with the latest bug fixes and features. That said, in a few situations, you may want to temporarily use an older version of a premium plugin. In this case, it's important that you also remain on a compatible version of The Events Calendar, even though updates may be available. If you need to downgrade to an earlier version of The Events Calendar, you can download it from our WordPress.org plugin page and install it manually. You'll want to be careful to avoid updating The Events Calendar until you are ready to update any premium plugins as well.

Please note that we can not provide any support for outdated versions of our plugins.